News

Jan 26th Protecting Against CVE-2016-0728

Overview A critical vulnerability in the Linux kernel was announced on Jan. 14, 2016, by security researchers at Perception Point. The vulnerability has existed since 2012, and is present in all devices running version 3.8 of the Linux kernel and higher. Impact The Linux kernel above version 3.8 is affected by CVE-2016-0728, including ... Read More »

Jan 19th Our Most Powerful Servers Just Got Faster!

Managed VPS with SSD & Great Cloud Features Providing you a vast array of tools to take your idea or business online today!   From site building tools and templates, to our one-click application installer, everything you need to launch a website ... Read More »